Unable to specify MaxFee

I’m specifying maxfee as max_fee = "10"; as specified in the ethereum.ros example but this isn’t reflected in the preprocess request.
Also should max_fee have a denomination, to address cases with multiple denom chains.
Can anyone help out what am I missing here

The max_fee used in the Ethereum example is only used to determine how much testnet ETH to send to the recipient (it is not sent to /construction/preprocess):

We do not yet support populating the ConstructionPreprocessRequest.MaxFee argument. We only support setting the entire value of Metadata (using <workflow>.preprocess_metadata):

If this is something you’d like to see added, please create an issue!

1 Like