How can i try to run `make salus`?

Hi, i’m trying to figure out the commands in Makefile.
And i met an error when i ran make salus.

Failed to load file:///salus.yaml

[INFORMATIONAL: 2022-04-26 05:11:00 +0000]: Salus is running.
RepoNotEmpty is scanning...
GoOSV is scanning...
RepoNotEmpty has finished
ReportGoDep is scanning...
ReportGoDep has finished
PatternSearch is scanning...
PatternSearch has finished
Gosec is scanning...
GoPackageScanner is scanning...
GoPackageScanner has finished
GoOSV has finished
Semgrep is scanning...
Semgrep has finished
[INFORMATIONAL: 2022-04-26 05:12:00 +0000]: Salus is running.
make: *** [salus-m1] Error 137
  • What make salus does?
  • How can i get salus.yaml file? And is there any example for that?

Thanks in advance :slight_smile:

1 Like

Hello! Which repository are you working with?

Recently, there was a PR merged to the rosetta-cli repo that fixed a problem with Salus. If that’s the repo you worked with, I would suggest reinstalling rosetta-cli and trying again. Let us know if that helped!

Thank you for replying.

Actually, I’m working on rosetta-ethereum repository.
And there is salus in Makefile.

I thought ‘make salus’ in rosetta-ethereum had nothing to do with rosetta-cli, is that correct?